Rebex.Elliptic.Castle by Rebex CR, s.r.o.

<PackageReference Include="Rebex.Elliptic.Castle" Version="1.2.1" />

 Rebex.Elliptic.Castle 1.2.1

Managed implementation of ECDH key exchange and ECDSA signature algorithms with a simple API. Based on https://www.bouncycastle.org/csharp/ Suitable for stand-alone usage or as a plugin for Rebex components. See https://labs.rebex.net/curves for usage instructions. Supported platforms: - .NET Framework 4.0-4.8 - .NET Framework 2.0-3.5 SP1 - .NET Core 2.0-3.1 (via .NET Standard 2.0) - .NET Core 1.0-1.1 (via .NET Standard 1.5) - Xamarin.iOS (10 and higher) - Xamarin.Android (9 and higher) - Mono 4.x, 5.x, 6.x - Universal Windows Platform build 16299 and higher (via .NET Standard 2.0) - Xamarin.Mac (via .NET Standard 2.0)

<package xmlns="http://schemas.microsoft.com/packaging/2013/05/nuspec.xsd">
  <metadata>
    <id>Rebex.Elliptic.Castle</id>
    <version>1.2.1</version>
    <title>Rebex.Elliptic.Castle</title>
    <authors>Rebex CR, s.r.o.</authors>
    <owners>Rebex CR, s.r.o.</owners>
    <requireLicenseAcceptance>true</requireLicenseAcceptance>
    <license type="file">LICENSE.txt</license>
    <licenseUrl>https://aka.ms/deprecateLicenseUrl</licenseUrl>
    <projectUrl>https://labs.rebex.net/curves</projectUrl>
    <description>Managed implementation of ECDH key exchange and ECDSA signature algorithms with a simple API.
Based on https://www.bouncycastle.org/csharp/

Suitable for stand-alone usage or as a plugin for Rebex components.
See https://labs.rebex.net/curves for usage instructions.

Supported platforms:
- .NET Framework 4.0-4.8
- .NET Framework 2.0-3.5 SP1
- .NET Core 2.0-3.1 (via .NET Standard 2.0)
- .NET Core 1.0-1.1 (via .NET Standard 1.5)
- Xamarin.iOS (10 and higher)
- Xamarin.Android (9 and higher)
- Mono 4.x, 5.x, 6.x
- Universal Windows Platform build 16299 and higher (via .NET Standard 2.0)
- Xamarin.Mac (via .NET Standard 2.0)</description>
    <tags>ECDSA ECDH ECC brainpool nistp256 nistp384 nistp521 elliptic curve cryptography</tags>
    <dependencies>
      <group targetFramework=".NETFramework2.0" />
      <group targetFramework=".NETFramework4.0" />
      <group targetFramework=".NETStandard2.0">
        <dependency id="NETStandard.Library" version="1.6.1" exclude="Build,Analyzers" />
      </group>
      <group targetFramework=".NETStandard1.5">
        <dependency id="NETStandard.Library" version="1.6.1" exclude="Build,Analyzers" />
      </group>
      <group targetFramework="Xamarin.iOS1.0" />
      <group targetFramework="MonoAndroid4.0" />
    </dependencies>
  </metadata>
</package>