ApexParser by ApexSharp.com

<PackageReference Include="ApexParser" Version="0.6.18" />

 ApexParser 0.6.18

A Roslyn-like parser for the Salesforce programming language APEX

<package xmlns="http://schemas.microsoft.com/packaging/2013/05/nuspec.xsd">
  <metadata>
    <id>ApexParser</id>
    <version>0.6.18</version>
    <authors>ApexSharp.com</authors>
    <owners>ApexSharp.com</owners>
    <requireLicenseAcceptance>false</requireLicenseAcceptance>
    <licenseUrl>https://github.com/apexsharp/apexparser/blob/master/LICENSE</licenseUrl>
    <projectUrl>https://github.com/apexsharp/apexparser/</projectUrl>
    <description>A Roslyn-like parser for the Salesforce programming language APEX</description>
    <releaseNotes>Beta release. What's new:

      v0.6.18:
      — Fixed a parsing issue related to SOQL queries

      v0.6.17:
      — Minor improvement in the primitive type conversion

      v0.6.16:
      — Improved the typeof expression handling
      — Added using Apex to the generated C# code

      v0.6.15:
      — All floating-point literals are now treated as decimals

      v0.6.14:
      — Added a few more autogenerated constructors to the Apex exceptions

      v0.6.13:
      — Don't translate static member access expressions on primitive types
      — Fixed an issue related to the field declarators
      — Added Apex.ApexSharp.Extensions namespace to generated C# code
      — Automatically add constructors to empty Apex exception classes
      — Updated reserved words

      v0.6.12:
      — Added support for the virtual class modifier

      v0.6.11:
      — Fixed a bug with string literals
      — Updated Sprache dependency to the stable v2.2.0

      v0.6.10:
      — Added switch statement support
      — Updated Roslyn C# parser dependency to v2.9.0

      v0.6.2:
      — Updated the grammar to be able to parse the standard APIs</releaseNotes>
    <copyright>© 2017-2018 ApexSharp.com</copyright>
    <tags>Apex, Parser, Roslyn</tags>
    <repository type="git" url="https://github.com/apexsharp/apexparser.git" />
    <dependencies>
      <group targetFramework=".NETFramework4.6.2">
        <dependency id="Microsoft.CodeAnalysis.CSharp" version="2.9.0" exclude="Build,Analyzers" />
        <dependency id="Sprache" version="2.2.0" exclude="Build,Analyzers" />
      </group>
      <group targetFramework=".NETStandard2.0">
        <dependency id="Microsoft.CodeAnalysis.CSharp" version="2.9.0" exclude="Build,Analyzers" />
        <dependency id="Sprache" version="2.2.0" exclude="Build,Analyzers" />
      </group>
    </dependencies>
  </metadata>
</package>